Some inbound numbers don’t reach our network.
Incident Report for Universal Cloud
Resolved
Our telecom provider confirmed that access to all our voice services has now been restored.

We are continuing to monitor the situation and investigating what caused this, and we will provide further information when we know more.

We will follow up with you if any other issues occur.

Apologies again for any inconvenience that might have been caused during this time.
Posted May 04, 2021 - 11:38 CEST
Monitoring
We see new calls coming in. The issue seems to be fixed. We keep monitoring en wait for the root cause analysis of our partner.
Posted May 04, 2021 - 11:12 CEST
Identified
The issue has been confirmed by our telecom provider. They are still evaluating the impact and root cause.
As soon as we have an update we will let you know.
Posted May 04, 2021 - 10:42 CEST
Investigating
We are investigation an issue where some inbound numbers don’t reach our network.
Posted May 04, 2021 - 10:27 CEST