Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 22:30 CEST
Scheduled
We will be performing a DNS switch to route traffic to our new Azure infrastructure. During this transition, some initiated voice calls may be temporarily fail.
We appreciate your patience and understanding as we work to improve our systems. If you experience any issues beyond the maintenance window, please contact our support team.
Posted Jun 25, 2025 - 22:29 CEST
This scheduled maintenance affected: Unified Communications (uWebChat Voice).