Users can't access Microsoft Power Apps
Incident Report for Universal Cloud
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 15:13 CET
Identified
Microsoft 365 Incident:

Title: Users can't access Microsoft Power Apps

User impact: Users may be unable to access Microsoft Power Apps.

Current status: We're monitoring the rollback as it propagates through the environment. We can see from telemetry that the service availability is improving as the rollback is progressing.

Scope of impact: All users may experience impact.

Start time: Thursday, November 16, 2023 at 5:05 AM GMT+1

Next update by: Thursday, November 16, 2023 at 12:00 PM GMT+1
Posted Nov 16, 2023 - 11:24 CET
This incident affected: MS 365 / Azure general (Power Platform).